Validates that the input CurveElements can define FaceRegions.
The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common
Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition,
a CurveElement must have the SketchOnSurface attribute set.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
C# |
---|
public static bool ValidateCurveElementIdArrayForFaceRegions(
Document document,
IList<ElementId> curveElemIds
) |
Visual Basic |
---|
Public Shared Function ValidateCurveElementIdArrayForFaceRegions ( _
document As Document, _
curveElemIds As IList(Of ElementId) _
) As Boolean |
Visual C++ |
---|
public:
static bool ValidateCurveElementIdArrayForFaceRegions(
Document^ document,
IList<ElementId^>^ curveElemIds
) |
Exceptions
See Also