Returns the worksharing display settings for the document, creating
new settings for the current user if necessary.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static WorksharingDisplaySettings GetOrCreateWorksharingDisplaySettings( Document doc ) |
Visual Basic |
---|
Public Shared Function GetOrCreateWorksharingDisplaySettings ( _ doc As Document _ ) As WorksharingDisplaySettings |
Visual C++ |
---|
public: static WorksharingDisplaySettings^ GetOrCreateWorksharingDisplaySettings( Document^ doc ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
The document of interest.
Return Value
The worksharing display settings for the document.
Remarks
Note that these settings are available even in models that are not
workshared. This is to allow pre-configuring the display settings
before enabling worksets so that they can be stored in template files.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | doc is not a project document. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |