Creates a new instance of Structural Section Flat Bar.
Namespace: Autodesk.Revit.DB.Structure.StructuralSectionsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public StructuralSectionGeneralF( double width, double height, double centroidHorizontal, double centroidVertical, StructuralSectionAnalysisParams analysisParams ) |
Visual Basic |
---|
Public Sub New ( _ width As Double, _ height As Double, _ centroidHorizontal As Double, _ centroidVertical As Double, _ analysisParams As StructuralSectionAnalysisParams _ ) |
Visual C++ |
---|
public: StructuralSectionGeneralF( double width, double height, double centroidHorizontal, double centroidVertical, StructuralSectionAnalysisParams^ analysisParams ) |
Parameters
- width
- Type: System..::..Double
Section width.
- height
- Type: System..::..Double
Section height, depth.
- centroidHorizontal
- Type: System..::..Double
Distance from centroid to the left extremites along horizontal axis.
- centroidVertical
- Type: System..::..Double
Distance from centroid to the upper extremites along vertical axis.
- analysisParams
- Type: Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSectionAnalysisParams
Common set of parameters for structural analysis.