Returns all numbers currently used in the given numbering sequence
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public IList<IntegerRange> GetNumbers( string partition ) |
Visual Basic |
---|
Public Function GetNumbers ( _ partition As String _ ) As IList(Of IntegerRange) |
Visual C++ |
---|
public: IList<IntegerRange^>^ GetNumbers( String^ partition ) |
Parameters
- partition
- Type: System..::..String
Name of the partition that identifies the sequence. The sequence must exist.
Return Value
A collection of integer ranges
Remarks
Numbers are returned as a collection of ranges, where each range is a pair of two integer values, Low and High. As long as there is no gap currently in the sequence, there will be only one range.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The sequence partition does not exist in the schema. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |