The Discipline of the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ViewDiscipline Discipline { get; set; } |
Visual Basic |
---|
Public Property Discipline As ViewDiscipline Get Set |
Visual C++ |
---|
public: property ViewDiscipline Discipline { ViewDiscipline get (); void set (ViewDiscipline value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | View must have a Discipline property -or- When setting this property: View Discipline must be modifiable. |