Sets the characters in a given text range to be italic or not italic.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public void SetItalicStatus( TextRange textRange, bool isItalic ) |
Visual Basic |
---|
Public Sub SetItalicStatus ( _ textRange As TextRange, _ isItalic As Boolean _ ) |
Visual C++ |
---|
public: void SetItalicStatus( TextRange^ textRange, bool isItalic ) |
Parameters
- textRange
- Type: Autodesk.Revit.DB..::..TextRange
The given text range.
- isItalic
- Type: System..::..Boolean
The desired italic status of characters in the given text range. True to set italic, false to set not italic.
Remarks
To make the numbers or letters in a list italic, apply the italic status to the carriage return character that ends the list paragraph.
The given text range should not be empty.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |