Geometric style of the leader
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public LeaderShape LeaderShape { get; } |
Visual Basic |
---|
Public ReadOnly Property LeaderShape As LeaderShape Get |
Visual C++ |
---|
public: property LeaderShape LeaderShape { LeaderShape get (); } |
Remarks
While this property cannot be changed directly, it can change, with limitations,
as an effect of other changes to either the leader itself or the annotation element
the leader is associated with. For example, straight-line leaders have no elbow
points; but if an elbow point is set for a straight leader, which is allowed, it will
effectively change the leader's shape to a kinked line.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | The leader is not currently owned by a valid element. A probable reason for that could be if the element has been independently deleted, or the leader has never been properly initialized. |