Checks if the curve is valid to be as the extents for the datum plane in a view.
The curve must be bound and coincident with the original one of the datum plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool IsCurveValidInView( DatumExtentType extentMode, View view, Curve curve ) |
Visual Basic |
---|
Public Function IsCurveValidInView ( _ extentMode As DatumExtentType, _ view As View, _ curve As Curve _ ) As Boolean |
Visual C++ |
---|
public: bool IsCurveValidInView( DatumExtentType extentMode, View^ view, Curve^ curve ) |
Parameters
- extentMode
- Type: Autodesk.Revit.DB..::..DatumExtentType
The extent type.
- view
- Type: Autodesk.Revit.DB..::..View
The view.
- curve
- Type: Autodesk.Revit.DB..::..Curve
The curve.
Return Value
True if it is valid, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |