Returns the default repeating reference source for a given element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static RepeatingReferenceSource GetDefaultRepeatingReferenceSource( Document document, ElementId elementId ) |
Visual Basic |
---|
Public Shared Function GetDefaultRepeatingReferenceSource ( _ document As Document, _ elementId As ElementId _ ) As RepeatingReferenceSource |
Visual C++ |
---|
public: static RepeatingReferenceSource^ GetDefaultRepeatingReferenceSource( Document^ document, ElementId^ elementId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document that contains the element.
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
The id of the element.
Return Value
The default repeating reference source of the given element.
Remarks
The element must support repeating references. Use HasRepeatingReferenceSource() to find out whether an element has any repeating references.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document -or- The element does not have any repeating reference sources. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |