Gets a collection of curves representing the DatumPlane element in the given view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public IList<Curve> GetCurvesInView( DatumExtentType extentMode, View view ) |
Visual Basic |
---|
Public Function GetCurvesInView ( _ extentMode As DatumExtentType, _ view As View _ ) As IList(Of Curve) |
Visual C++ |
---|
public: IList<Curve^>^ GetCurvesInView( DatumExtentType extentMode, View^ view ) |
Parameters
- extentMode
- Type: Autodesk.Revit.DB..::..DatumExtentType
The extent type.
- view
- Type: Autodesk.Revit.DB..::..View
The view.
Return Value
The curves.
Remarks
Curves returned for Model extents can be different than curves returned for View-specific extents (2d extents) in the given view.
In some cases, such as an arc grid in a section view, there will be two identical curves but offset from one another.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |