Creates a new ElevationMarker.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
Visual Basic |
---|
Public Shared Function CreateElevationMarker ( _
document As Document, _
viewFamilyTypeId As ElementId, _
origin As XYZ, _
initialViewScale As Integer _
) As ElevationMarker |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to which the new ElevationMarker will be added.
- viewFamilyTypeId
- Type: Autodesk.Revit.DB..::..ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
- origin
- Type: Autodesk.Revit.DB..::..XYZ
The desired origin for the ElevationMarker.
- initialViewScale
- Type: System..::..Int32
This view scale will be automatically applied to new elevations created on the ElevationMarker.
The scale is the ratio of true model size to paper size.
Return Value
The new ElevationMarker.
Exceptions
See Also