Creates a new radial grid line.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Shared Function Create ( _
document As Document, _
arc As Arc _
) As Grid |
Return Value
The newly created grid line.
Remarks
Examples
CopyC#
XYZ end0 = new XYZ(0, 0, 0);
XYZ end1 = new XYZ(10, 40, 0);
XYZ pointOnCurve = new XYZ(5, 7, 0);
Arc geomArc = Arc.Create(end0, end1, pointOnCurve);
Grid arcGrid = Grid.Create(document, geomArc);
if (null == arcGrid)
{
throw new Exception("Create a new curved grid failed.");
}
arcGrid.Name = "New Name2";
CopyVB.NET
Dim end0 As New XYZ(0, 0, 0)
Dim end1 As New XYZ(10, 40, 0)
Dim pointOnCurve As New XYZ(5, 7, 0)
Dim geomArc As Arc = Arc.Create(end0, end1, pointOnCurve)
Dim arcGrid As Grid = Grid.Create(document, geomArc)
If arcGrid Is Nothing Then
Throw New Exception("Create a new curved grid failed.")
End If
arcGrid.Name = "New Name2"
Exceptions
See Also