Defines bar bend diameter for rebar whose style is standard
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double StandardBendDiameter { get; set; } |
Visual Basic |
---|
Public Property StandardBendDiameter As Double Get Set |
Visual C++ |
---|
public: property double StandardBendDiameter { double get (); void set (double value); } |
Field Value
The bar bend diameter for rebar whose style is standard
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the bend diameter standardBendDiam isn't between bar diameter and 99.0 |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |