Creates a new Solid which is a copy of the input Solid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public static Solid Clone( Solid solid ) |
Visual Basic |
---|
Public Shared Function Clone ( _ solid As Solid _ ) As Solid |
Visual C++ |
---|
public: static Solid^ Clone( Solid^ solid ) |
Parameters
- solid
- Type: Autodesk.Revit.DB..::..Solid
The input solid to be copied.
Return Value
The newly created Solid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |