Make BRepBuilder allow edges that it would normally disallow as being too short for Revit geometry.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017_subscription_update
Syntax
C# |
---|
public void SetAllowShortEdges() |
Visual Basic |
---|
Public Sub SetAllowShortEdges |
Visual C++ |
---|
public: void SetAllowShortEdges() |
Remarks
When used, this function must be called before any geometry is defined (e.g., just after constructing a BRepBuilder object).
Geometry with short edges may not be as reliable as fully valid geometry.
This option is intended to allow the construction of geometry such as mechanical items with small features
that is not expected to interact much with other Revit elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This function was called after the geometry had been defined (e.g. by calls to addFace). |