Constructs a new instance of a filter to match elements in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public ElementWorksetFilter(
	WorksetId worksetId,
	bool inverted
)
Visual Basic
Public Sub New ( _
	worksetId As WorksetId, _
	inverted As Boolean _
)
Visual C++
public:
ElementWorksetFilter(
	WorksetId^ worksetId, 
	bool inverted
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
The workset id to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not in the given workset.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also