Sets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public void SetExtendableRegionIds(
	bool top,
	IList<int> regionIds
)
Visual Basic
Public Sub SetExtendableRegionIds ( _
	top As Boolean, _
	regionIds As IList(Of Integer) _
)
Visual C++
public:
void SetExtendableRegionIds(
	bool top, 
	IList<int>^ regionIds
)

Parameters

top
Type: System..::..Boolean
If true, set ids of regions which are extendable at the top, otherwise set the ids of regions which are extendable at the bottom.
regionIds
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
The ids of regions which will be extendable.

Remarks

Regions along the top or bottom of the wall may be set to be extendable.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException The region ids are not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException This operation is valid only for vertically compound structures.

See Also