Returns the origin point of a scan in model coordinates.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public XYZ GetScanOrigin( string scanName ) |
Visual Basic |
---|
Public Function GetScanOrigin ( _ scanName As String _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ GetScanOrigin( String^ scanName ) |
Parameters
- scanName
- Type: System..::..String
Name of the scan.
Return Value
Resulting origin point of the scan.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | PointCloudInstance does not contain scan scanName. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |