Sets the FormatOptions to optionally override the default settings in the Units class.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void SetFormatOptions( FormatOptions formatOptions ) |
Visual Basic |
---|
Public Sub SetFormatOptions ( _ formatOptions As FormatOptions _ ) |
Visual C++ |
---|
public: void SetFormatOptions( FormatOptions^ formatOptions ) |
Parameters
- formatOptions
- Type: Autodesk.Revit.DB..::..FormatOptions
The FormatOptions.
Remarks
By default, the FormatOptions represents default formatting
(UseDefault is true) and the FormatOptions in the Units class will
be used.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |