Saves shared coordinates changes back to the linked document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool SavePositions( ISaveSharedCoordinatesCallback callback ) |
Visual Basic |
---|
Public Function SavePositions ( _ callback As ISaveSharedCoordinatesCallback _ ) As Boolean |
Visual C++ |
---|
public: bool SavePositions( ISaveSharedCoordinatesCallback^ callback ) |
Parameters
- callback
- Type: Autodesk.Revit.DB..::..ISaveSharedCoordinatesCallback
A callback object to resolve situations when Revit encounters modified links.
Return Value
True if we saved the link or if there were no changes to save. False if the operation failed.
Remarks
While this operation does not clear the document's undo history,
you will not be able to undo this specific action, since it saves
the link's shared coordinates changes to disk.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Revit could not save shared coordinates changes to the link or one of its nested links. |