Returns the indent level of the paragraphs in the text range.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public int GetIndentLevel( TextRange textRange ) |
Visual Basic |
---|
Public Function GetIndentLevel ( _ textRange As TextRange _ ) As Integer |
Visual C++ |
---|
public: int GetIndentLevel( TextRange^ textRange ) |
Parameters
- textRange
- Type: Autodesk.Revit.DB..::..TextRange
The given text range.
Return Value
The indentation level of the paragraphs in the range.
Remarks
Returns -1 if the range contains multiple paragraphs with different indent levels.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |