Gets the condition upper value (valid if less) for a given condition index.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public double GetConditionUpperValue( int condition ) |
Visual Basic |
---|
Public Function GetConditionUpperValue ( _ condition As Integer _ ) As Double |
Visual C++ |
---|
public: double GetConditionUpperValue( int condition ) |
Parameters
- condition
- Type: System..::..Int32
The condition index.
Return Value
The condition upper value.
Remarks
A value of -1 indicates an unrestricted value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index condition is not larger or equal to 0 and less than ConditionCount |