The dimension style type to be used by the new MultiReferenceAnnotation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public DimensionStyleType DimensionStyleType { get; set; } |
Visual Basic |
---|
Public Property DimensionStyleType As DimensionStyleType Get Set |
Visual C++ |
---|
public: property DimensionStyleType DimensionStyleType { DimensionStyleType get (); void set (DimensionStyleType value); } |
Remarks
Only Linear and LinearFixed types are allowed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: dimensionStyleType must be either Linear or LinearFixed to be used by MultiReferenceAnnotations. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |