Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Parameters
- isSolid
- Type: System..::..Boolean
Indicates if the Form is Solid or Void.
- path
- Type: Autodesk.Revit.DB..::..ReferenceArray
The path of the swept blend. The path should be 2D, where all input curves lie in one plane. If there's more than one profile, the path should be a single curve.
It's required to reference existing geometry.
- profiles
- Type: Autodesk.Revit.DB..::..ReferenceArrayArray
The profile set of the newly created swept blend. Each profile should consist of only one curve loop.
Each profile must be in a plane that intersects with the path and is perpendicular to the path at the point of intersection.
Return Value
If creation was successful new form is returned.
See Also