Sets the railing path.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
Visual Basic |
---|
Public Sub SetPath ( _
curveLoop As CurveLoop _
) |
Visual C++ |
---|
public:
void SetPath(
CurveLoop^ curveLoop
) |
Parameters
- curveLoop
- Type: Autodesk.Revit.DB..::..CurveLoop
The railing path along which the new railing will be created.
The curveLoop should be continuous with curves which are only bounded lines and arcs on the same horizontal plane.
It also has to have maximum two curves meet in one end point.
Exceptions
See Also