Gets the extents for the given curve segment generated by intersection.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public CurveExtents GetCurveSegmentExtents( int index ) |
Visual Basic |
---|
Public Function GetCurveSegmentExtents ( _ index As Integer _ ) As CurveExtents |
Visual C++ |
---|
public: CurveExtents^ GetCurveSegmentExtents( int index ) |
Parameters
- index
- Type: System..::..Int32
The index.
Return Value
The curve extents.
Remarks
The parameters are raw parameters based on the raw parameter extents of the original input curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range. |