Returns all AreaReinforcement elements hosted by the referenced element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public IList<AreaReinforcement> GetAreaReinforcementsInHost() |
Visual Basic |
---|
Public Function GetAreaReinforcementsInHost As IList(Of AreaReinforcement) |
Visual C++ |
---|
public: IList<AreaReinforcement^>^ GetAreaReinforcementsInHost() |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |