Creates a new PropertySetElement to contain the given asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public static PropertySetElement Create(
	Document document,
	StructuralAsset structuralAsset
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	structuralAsset As StructuralAsset _
) As PropertySetElement
Visual C++
public:
static PropertySetElement^ Create(
	Document^ document, 
	StructuralAsset^ structuralAsset
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
structuralAsset
Type: Autodesk.Revit.DB..::..StructuralAsset
The structural asset containing the values that will be present in the PropertySetElement.

Return Value

The new PropertySetElement.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also