Save the current view sheet set to another view sheet set with the specified name.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool SaveAs( string newName ) |
Visual Basic |
---|
Public Function SaveAs ( _ newName As String _ ) As Boolean |
Visual C++ |
---|
public: bool SaveAs( String^ newName ) |
Parameters
- newName
- Type: System..::..String
View sheet set name to be saved as.
Return Value
False if Save As operation fails, otherwise True.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input name is already existed in current view sheet set list. |