Multiplier of bar diameter. Used to compute a default hook length.
The default hook length can be overridden by the RebarBarType class.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double StraightLineMultiplier { get; set; } |
Visual Basic |
---|
Public Property StraightLineMultiplier As Double Get Set |
Visual C++ |
---|
public: property double StraightLineMultiplier { double get (); void set (double value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for straightLineMultiplier is not a number |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: straightLineMultiplier must be greater than 0 and no more than 99. |