Segregates a set of elements into subsets which are
valid for merge.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static IList<ICollection<ElementId>> FindMergeableClusters( Document doc, ICollection<ElementId> partIds ) |
Visual Basic |
---|
Public Shared Function FindMergeableClusters ( _ doc As Document, _ partIds As ICollection(Of ElementId) _ ) As IList(Of ICollection(Of ElementId)) |
Visual C++ |
---|
public: static IList<ICollection<ElementId^>^>^ FindMergeableClusters( Document^ doc, ICollection<ElementId^>^ partIds ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
The document.
- partIds
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids.
Return Value
An array of clusters such that all the elements in a single cluster are valid for merge. Each cluster will be maximal in that appending any of the other Parts specified as input will result in a collection that is not valid for merge.
Remarks
Element ids in the input set that do not correspond to Part
elements will be ignored, as will element ids corresponding
to Part elements that already have associated parts.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |