Returns the TargetRebarConstraintType of the handle on the other Rebar Element
to which this RebarConstraint is attached. The RebarConstraintType of the
RebarConstraint must be 'ToOtherRebar.'
Rebar must be Shape Driven Rebar element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public TargetRebarConstraintType GetTargetRebarConstraintType() |
Visual Basic |
---|
Public Function GetTargetRebarConstraintType As TargetRebarConstraintType |
Visual C++ |
---|
public: TargetRebarConstraintType GetTargetRebarConstraintType() |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- Constrained rebar is a free form rebar element. |