Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public PointOnEdgeFaceIntersection NewPointOnEdgeFaceIntersection( Reference edgeReference, Reference faceReference, bool orientWithEdge ) |
Visual Basic |
---|
Public Function NewPointOnEdgeFaceIntersection ( _ edgeReference As Reference, _ faceReference As Reference, _ orientWithEdge As Boolean _ ) As PointOnEdgeFaceIntersection |
Visual C++ |
---|
public: PointOnEdgeFaceIntersection^ NewPointOnEdgeFaceIntersection( Reference^ edgeReference, Reference^ faceReference, bool orientWithEdge ) |
Parameters
- edgeReference
- Type: Autodesk.Revit.DB..::..Reference
The edge reference.
- faceReference
- Type: Autodesk.Revit.DB..::..Reference
The face reference.
- orientWithEdge
- Type: System..::..Boolean
Return Value
A new PointOnEdgeFaceIntersection object.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument edgeReference or faceReference is nullNothingnullptra null reference (Nothing in Visual Basic). |