Creates a new hosted point load within the project.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public static PointLoad Create( Document aDoc, AnalyticalModel host, XYZ forceVector, XYZ momentVector, PointLoadType symbol ) |
Visual Basic |
---|
Public Shared Function Create ( _ aDoc As Document, _ host As AnalyticalModel, _ forceVector As XYZ, _ momentVector As XYZ, _ symbol As PointLoadType _ ) As PointLoad |
Visual C++ |
---|
public: static PointLoad^ Create( Document^ aDoc, AnalyticalModel^ host, XYZ^ forceVector, XYZ^ momentVector, PointLoadType^ symbol ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
Document to which new point load will be added.
- host
- Type: Autodesk.Revit.DB.Structure..::..AnalyticalModel
The Analytical Isolated Foundation type host element for the point Load.
- forceVector
- Type: Autodesk.Revit.DB..::..XYZ
The applied 3d force vector.
- momentVector
- Type: Autodesk.Revit.DB..::..XYZ
The applied 3d moment vector.
- symbol
- Type: Autodesk.Revit.DB.Structure..::..PointLoadType
The symbol of the PointLoad. Set nullNothingnullptra null reference (Nothing in Visual Basic) to use default type.
Return Value
If successful, returns the newly created PointLoad, nullNothingnullptra null reference (Nothing in Visual Basic) otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The element host was not found in the given document. -or- Thrown when host is not an Analytical Isolated Foundation type host element. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when force and moment vectors are equal zero. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if type could not be set for newly created point load. |