Gets the ids of region bound to a specified segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public IList<int> GetAdjacentRegions(
int segmentId
) |
Visual Basic |
---|
Public Function GetAdjacentRegions ( _
segmentId As Integer _
) As IList(Of Integer) |
Visual C++ |
---|
public:
IList<int>^ GetAdjacentRegions(
int segmentId
) |
Parameters
- segmentId
- Type: System..::..Int32
The id of a segment in this CompoundStructure.
Return Value
The ids of the regions that are bounded by the specified segment.
Remarks
Exceptions
See Also