Sets the major layout pattern as NumberWithSpacing, while specifying the needed parameters for this pattern.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
C# |
---|
public void SetMinorLayoutAsNumberWithSpacing(
double overallLength,
double majorStartOverhang,
int numberOfWires,
double spacing
) |
Visual Basic |
---|
Public Sub SetMinorLayoutAsNumberWithSpacing ( _
overallLength As Double, _
majorStartOverhang As Double, _
numberOfWires As Integer, _
spacing As Double _
) |
Visual C++ |
---|
public:
void SetMinorLayoutAsNumberWithSpacing(
double overallLength,
double majorStartOverhang,
int numberOfWires,
double spacing
) |
Parameters
- overallLength
- Type: System..::..Double
The entire length of the wire sheet in the major direction.
- majorStartOverhang
- Type: System..::..Double
The distance from the edge of the sheet to the first wire in the major direction.
- numberOfWires
- Type: System..::..Int32
The number of wires in the minor direction.
- spacing
- Type: System..::..Double
The distance between the wires in the minor direction.
Exceptions
See Also