Returns the AssemblyCodeTable for the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2015

Syntax

C#
public static AssemblyCodeTable GetAssemblyCodeTable(
	Document doc
)
Visual Basic
Public Shared Function GetAssemblyCodeTable ( _
	doc As Document _
) As AssemblyCodeTable
Visual C++
public:
static AssemblyCodeTable^ GetAssemblyCodeTable(
	Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document owns the AssemblyCodeTable.

Return Value

The AssemblyCodeTable for the document.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also