Returns set of elements that were modified according to the given element filter.
Namespace: Autodesk.Revit.DB.EventsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public ICollection<ElementId> GetModifiedElementIds( ElementFilter filter ) |
Visual Basic |
---|
Public Function GetModifiedElementIds ( _ filter As ElementFilter _ ) As ICollection(Of ElementId) |
Visual C++ |
---|
public: ICollection<ElementId^>^ GetModifiedElementIds( ElementFilter^ filter ) |
Parameters
- filter
- Type: Autodesk.Revit.DB..::..ElementFilter
The element filter to be applied.
Return Value
The set of ElementId for modified elements that pass the filter. Returns empty set if no elements are found which pass the filter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |