Gets the routing condition at the specified index position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public RoutingCondition GetConditionAt(
	int index
)
Visual Basic
Public Function GetConditionAt ( _
	index As Integer _
) As RoutingCondition
Visual C++
public:
RoutingCondition^ GetConditionAt(
	int index
)

Parameters

index
Type: System..::..Int32
The 0-based index to access the collection of available conditions. The method throws the exception ArgumentOutOfRangeException if the index is out of range.

Return Value

The found routing condition.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException index is not within the valid range of available conditions.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also