Divides this vector by the specified value and returns the result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public XYZ Divide( double value ) |
Visual Basic |
---|
Public Function Divide ( _ value As Double _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ Divide( double value ) |
Parameters
- value
- Type: System..::..Double
The value to divide this vector by.
Return Value
The divided vector.
Remarks
The divided vector is obtained by dividing each coordinate of
this vector by the specified value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number or zero. |