Creates a new sketch plane from a geometric plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static SketchPlane Create( Document document, Plane plane ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ plane As Plane _ ) As SketchPlane |
Visual C++ |
---|
public: static SketchPlane^ Create( Document^ document, Plane^ plane ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- plane
- Type: Autodesk.Revit.DB..::..Plane
The geometry plane where the sketch plane will be created.
Return Value
The newly created sketch plane.
Remarks
There will not be a reference relationship established from the sketch plane to the input face. To create a SketchPlane with a reference to other geometry,
use the overload with a Reference input.
Examples

public static SketchPlane CreateSketchPlane(Autodesk.Revit.DB.Document document, Plane plane) { SketchPlane sketchPlane = null; // create a sketch plane using Geometry.Plane sketchPlane = SketchPlane.Create(document, plane); // throw exception if creation failed if (null == sketchPlane) { throw new Exception("Create the sketch plane failed."); } return sketchPlane; }

Public Shared Function CreateSketchPlane(document As Autodesk.Revit.DB.Document, plane As Plane) As SketchPlane Dim sketchPlane__1 As SketchPlane = Nothing ' create a sketch plane using Geometry.Plane sketchPlane__1 = SketchPlane.Create(document, plane) ' throw exception if creation failed If sketchPlane__1 Is Nothing Then Throw New Exception("Create the sketch plane failed.") End If Return sketchPlane__1 End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Sketch plane creation is not allowed in this family. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |