The horizontal length of the notch profile.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public double NotchExtension { get; set; } |
Visual Basic |
---|
Public Property NotchExtension As Double Get Set |
Visual C++ |
---|
public: property double NotchExtension { double get (); void set (double value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for notchExtension must be no more than 30000 feet in absolute value. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The construction method of the stairs type is not "Precast" or the StairsEndConnectionType of the stairs type is not "Notch", so this related data cannot be set. |