Maps a portion of the buffer into memory, so that vertex data can be written into it.
(see
VertexStream).
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
C# |
---|
public void Map(
int sizeInFloats
) |
Visual Basic |
---|
Public Sub Map ( _
sizeInFloats As Integer _
) |
Visual C++ |
---|
public:
void Map(
int sizeInFloats
) |
Parameters
- sizeInFloats
- Type: System..::..Int32
The size of the part of the buffer to be mapped, measured in floats.
Must be less than or equal to the size of the VertexBuffer
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
This VertexBuffer is not available because Revit is not currently rendering. In general, this VertexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
-or-
Thrown if the buffer is smaller than sizeInFloats.
|
See Also