Gets the Building Construction override for a ConstructionType.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public bool GetBuildingConstructionOverride(
	ConstructionType constructionType
)
Visual Basic
Public Function GetBuildingConstructionOverride ( _
	constructionType As ConstructionType _
) As Boolean
Visual C++
public:
bool GetBuildingConstructionOverride(
	ConstructionType constructionType
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::..ConstructionType
The ConstructionType override value to get.

Return Value

True if analytical construction properties specified in Constructions.xml are used for the given ConstructionType, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException The ConstructionType is invalid.

See Also