The id of the template view that controls this view's parameters.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ElementId ViewTemplateId { get; set; } |
Visual Basic |
---|
Public Property ViewTemplateId As ElementId Get Set |
Visual C++ |
---|
public: property ElementId^ ViewTemplateId { ElementId^ get (); void set (ElementId^ value); } |
Field Value
The id of the template view that controls this view's parameters. InvalidElementId if there is no template set for this view.
Remarks
Parameters controlled by the template cannot be changed directly in this view.
Any change to controlled parameters in the template will cause change of the corresponding parameters in this view.
Use GetTemplateParameterIds()()()() on the template view to get a list of all template parameters.
Use GetNonControlledTemplateParameterIds()()()() on the template view to get parameters that are not controlled by the template.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: val is not valid as a view template id for this view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |