True to enable volume computation. False to disable it.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool ComputeVolumes { get; set; } |
Visual Basic |
---|
Public Property ComputeVolumes As Boolean Get Set |
Visual C++ |
---|
public: property bool ComputeVolumes { bool get (); void set (bool value); } |
Remarks
When this setting is False, rooms and spaces will be treated as simple extrusions of their 2d boundaries.
The volume parameter will report "not computed".
When this setting is True, the geometry of rooms and spaces will be trimmed
when it intersects elements such as ceilings, roofs, and floors.
Examples

public void GetRoomDimensions(Document doc, Room room) { String roominfo = "Room dimensions:\n"; // turn on volume calculations: using (Transaction t = new Transaction(doc, "Turn on volume calculation")) { t.Start(); AreaVolumeSettings settings = AreaVolumeSettings.GetAreaVolumeSettings(doc); settings.ComputeVolumes = true; t.Commit(); } roominfo += "Vol: " + room.Volume + "\n"; roominfo += "Area: " + room.Area + "\n"; roominfo += "Perimeter: " + room.Perimeter + "\n"; roominfo += "Unbounded height: " + room.UnboundedHeight + "\n"; TaskDialog.Show("Revit",roominfo); }

Public Sub GetRoomDimensions(doc As Document, room As Room) Dim roominfo As [String] = "Room dimensions:" & vbLf ' turn on volume calculations: Using t As New Transaction(doc, "Turn on volume calculation") t.Start() Dim settings As AreaVolumeSettings = AreaVolumeSettings.GetAreaVolumeSettings(doc) settings.ComputeVolumes = True t.Commit() End Using roominfo += "Vol: " & Convert.ToString(room.Volume) & vbLf roominfo += "Area: " & Convert.ToString(room.Area) & vbLf roominfo += "Perimeter: " & Convert.ToString(room.Perimeter) & vbLf roominfo += "Unbounded height: " & Convert.ToString(room.UnboundedHeight) & vbLf TaskDialog.Show("Revit", roominfo) End Sub