The sketch plane assigned to the view for model curve creation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public SketchPlane SketchPlane { get; set; } |
Visual Basic |
---|
Public Property SketchPlane As SketchPlane Get Set |
Visual C++ |
---|
public: property SketchPlane^ SketchPlane { SketchPlane^ get (); void set (SketchPlane^ value); } |
Field Value
The sketch plane, or nullNothingnullptra null reference (Nothing in Visual Basic) for views which don't allow sketching (such as schedules) or for views that allow model curve creation but have no current sketch plane assigned.
Remarks
If this property is set in when the current work plane is visible, the updated work plane will not be shown until the current
transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the property to nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the property to a sketch plane that cannot be used to create model elements, or when the input sketch plane is orthogonal to the view orientation. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting the property to a view that does not permit model curve creation, or when other errors occur. |