Flag indicating whether elements of this material behave isotropically or orthotropically.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public StructuralBehavior Behavior { get; set; } |
Visual Basic |
---|
Public Property Behavior As StructuralBehavior Get Set |
Visual C++ |
---|
public: property StructuralBehavior Behavior { StructuralBehavior get (); void set (StructuralBehavior value); } |
Remarks
Applies to concrete, Metal, and generic structural assets.
If the behavior is set to Isotropic, then the y and z components of Young modulus,
Poisson modulus, shear modulus and thermal expansion coefficient will be changed to
the value the same as their x components.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |