Whether to check member supports for circular references.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool AnalyticalModelCheckCircularReferences { get; set; } |
Visual Basic |
---|
Public Property AnalyticalModelCheckCircularReferences As Boolean Get Set |
Visual C++ |
---|
public: property bool AnalyticalModelCheckCircularReferences { bool get (); void set (bool value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |