Returns an object for managing view crop region shape for reference callout.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static ViewCropRegionShapeManager GetCropRegionShapeManagerForReferenceCallout( Document doc, ElementId callout ) |
Visual Basic |
---|
Public Shared Function GetCropRegionShapeManagerForReferenceCallout ( _ doc As Document, _ callout As ElementId _ ) As ViewCropRegionShapeManager |
Visual C++ |
---|
public: static ViewCropRegionShapeManager^ GetCropRegionShapeManagerForReferenceCallout( Document^ doc, ElementId^ callout ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
Document to which the callout belongs.
- callout
- Type: Autodesk.Revit.DB..::..ElementId
Element id of reference callout.
Return Value
The crop region shape manager.
Remarks
Reference callout is a view-specific element referencing another view.
It can have its own crop region shape which doesn't affect the referenced view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |